Frank Filz has uploaded this change for review.

View Change

nfs_ip_name cache: Larger hostname buffer and other fixes

getnameinfo specifies using NI_MAXHOST as the size that should be used
for the hostname buffer.

Just use the caller's buffer to getnameinfo into to save a copy.

Make the hostname dynamic sized in nfs_ip_name_t

Even if there is a hash error, we still resolved the ipaddress into
a hostname or didn't and are going to just use the ipaddress as the name,
so no reason to fail to return what would have been cached to the caller.

Make sure all the string copies are safe and report an error if the buffers
are too small.

Change-Id: I9f5daaf632026dce9882003260e43bd17ae5fc25
Signed-off-by: Frank S. Filz <ffilzlnx@mindspring.com>
---
M src/include/nfs_ip_stats.h
M src/support/exports.c
M src/support/nfs_ip_name.c
3 files changed, 66 insertions(+), 51 deletions(-)

git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/39/454939/1

To view, visit change 454939. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-Change-Id: I9f5daaf632026dce9882003260e43bd17ae5fc25
Gerrit-Change-Number: 454939
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx@mindspring.com>
Gerrit-MessageType: newchange