[M] Change in ...nfs-ganesha[next]: Dynamic delegation option parsing handling for VFS
Animesh Javali has uploaded this change for review. ( https://review.gerrithub.io/c/ffilz/nfs-ganesha/+/1229172?usp=email ) Change subject: Dynamic delegation option parsing handling for VFS ...................................................................... Dynamic delegation option parsing handling for VFS Code changes include: - Added a default method to handle_deleg_transition() which would be called for VFS FSAL. - Added a check to prevent invocation of mdcache_handle_deleg_transition when delegation is disabled in the NFSv4 block. - Added USE_FSAL_CEPH_LL_DELEGATION macro to make dynamic delegation option parsing code path safer. - Changed the naming for better code readability. Change-Id: If5e2714266c868be727ab5070db03c9560f28a16 Signed-off-by: Animesh Javali <Animesh.Javali@ibm.com> --- M src/FSAL/FSAL_CEPH/main.c M src/FSAL/Stackable_FSALs/FSAL_MDCACHE/mdcache_main.c M src/FSAL/default_methods.c M src/MainNFSD/libganesha_nfsd.ver M src/include/fsal_api.h M src/include/mdcache.h M src/support/exports.c 7 files changed, 53 insertions(+), 26 deletions(-) git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/72/1229172/1 -- To view, visit https://review.gerrithub.io/c/ffilz/nfs-ganesha/+/1229172?usp=email To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings?usp=email Gerrit-MessageType: newchange Gerrit-Project: ffilz/nfs-ganesha Gerrit-Branch: next Gerrit-Change-Id: If5e2714266c868be727ab5070db03c9560f28a16 Gerrit-Change-Number: 1229172 Gerrit-PatchSet: 1 Gerrit-Owner: Animesh Javali <Animesh.Javali@ibm.com>
participants (1)
-
Animesh Javali (GerritHub)