Branch next Tag:V2.7-dev.18 Release Highlights * MDCACHE various debugging of dirent cache * MDCACHE: For dirent chunking, prevent prev_chunk from being reaped * MDCACHE: Replace chunk accounting with dirent accounting * config_samples: remove obsolete config params from sample ceph.conf * misc rados grace updates * SAL - Fix coverity error: limit on cleanup was broken * GTest - fix name too short error * MEM - Limit dirent readahead to 1 chunk * FSAL_VFS : only_one_user mode Signed-off-by: Frank S. Filz <ffilzlnx@mindspring.com> Contents: 39b5229 Frank S. Filz V2.7-dev.18 7ab8716 Patrice LUCAS FSAL_VFS : only_one_user mode 001940e Daniel Gryniewicz MEM - Limit dirent readahead to 1 chunk 4238c53 Daniel Gryniewicz GTest - fix name too short error 1a20c41 Daniel Gryniewicz SAL - Fix coverity error: limit on cleanup was broken 0f0feee Jeff Layton specfile: move ganesha-rados-grace into a separate package bfaba71 Jeff Layton ganesha-rados-grace: rename rados_grace_tool to ganesha-rados-grace b86321e Jeff Layton config_samples: remove obsolete config params from sample ceph.conf e9d8dea Frank S. Filz MDCACHE: make all dirent related functions use LogDebugAlt/LogFullDebugAlt c7c336e Frank S. Filz MDCACHE: Replace chunk accounting with dirent accounting 831453c Frank S. Filz MDCACHE: For dirent chunking, prevent prev_chunk from being reaped de35287 Frank S. Filz MDCACHE: Add some next_ck debugging for dirent chunks