From Jeff Layton <jlayton@redhat.com>: Jeff Layton has uploaded this change for review. ( https://review.gerrithub.io/423943 Change subject: SAL: recovery_backend API cleanups ...................................................................... SAL: recovery_backend API cleanups Remove prototype for simple_try_lift_grace, as it no longer exists. Rename nfs4_end_grace to nfs_end_grace for better parity with related functions. Reorganize the header file a bit to co-locate related API functions. Clean up the definitions of the global grace-period tracking variables, and add some comments to clarify what the grace_mutex protects. Change-Id: I549844d0d3b5acd7decf6fe25e694a5fd5b79aa6 Signed-off-by: Jeff Layton <jlayton@redhat.com> --- M src/SAL/nfs4_recovery.c M src/include/sal_functions.h 2 files changed, 18 insertions(+), 10 deletions(-) git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/43/423943/1 -- To view, visit https://review.gerrithub.io/423943 To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings Gerrit-Project: ffilz/nfs-ganesha Gerrit-Branch: next Gerrit-MessageType: newchange Gerrit-Change-Id: I549844d0d3b5acd7decf6fe25e694a5fd5b79aa6 Gerrit-Change-Number: 423943 Gerrit-PatchSet: 1 Gerrit-Owner: Jeff Layton <jlayton@redhat.com>