Change in ffilz/nfs-ganesha[next]: [GPFS] Handle failures with NFS readdir operation
by GerritHub
From Malahal <malahal(a)gmail.com>:
Malahal has uploaded this change for review. ( https://review.gerrithub.io/431244
Change subject: [GPFS] Handle failures with NFS readdir operation
......................................................................
[GPFS] Handle failures with NFS readdir operation
We use getdents64 syscall to get directory entries and then use lookup
while filling each of such entries. The entry may not exist by the time
we do lookup, so handle non-existing errors from the lookup.
Change-Id: I32cdeaaea2d3f197279983dc194257d79615be13
Signed-off-by: Malahal Naineni <malahal(a)us.ibm.com>
---
M src/FSAL/FSAL_GPFS/handle.c
1 file changed, 17 insertions(+), 2 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/44/431244/1
--
To view, visit https://review.gerrithub.io/431244
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I32cdeaaea2d3f197279983dc194257d79615be13
Gerrit-Change-Number: 431244
Gerrit-PatchSet: 1
Gerrit-Owner: Malahal <malahal(a)gmail.com>
6 years, 1 month
Change in ffilz/nfs-ganesha[next]: Make nfs4 read and write async capable
by GerritHub
From Frank Filz <ffilzlnx(a)mindspring.com>:
Frank Filz has uploaded this change for review. ( https://review.gerrithub.io/431234
Change subject: Make nfs4 read and write async capable
......................................................................
Make nfs4 read and write async capable
Change-Id: Ia5b93e9381ba0d67445c378d1745f8317525db85
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
---
M src/Protocols/NFS/nfs4_op_read.c
M src/Protocols/NFS/nfs4_op_write.c
2 files changed, 97 insertions(+), 17 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/34/431234/1
--
To view, visit https://review.gerrithub.io/431234
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: Ia5b93e9381ba0d67445c378d1745f8317525db85
Gerrit-Change-Number: 431234
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx(a)mindspring.com>
6 years, 1 month
Announce Push of V2.8-dev.3
by Frank Filz
Branch next
Tag:V2.8-dev.3
Release Highlights
* GLUSTER: support delegations
* rpc_callback : check return value for nfs_rpc_create_chan_v40() properly
* Add support for LTTng on external ntirpc
* Fix xprt initial refs
* Remove unexported filesystems on DBUS unexport.
* Acquire state's fdlock in close2
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
Contents:
a650c29 Frank S. Filz V2.8-dev.3
4a05508 Soumya Koduri Acquire state's fdlock in close2
fab810d Krishna Harathi Remove unexported export on DBUS unexport.
2013454 Daniel Gryniewicz Fix xprt initial refs
c8afe52 Daniel Gryniewicz Add support for LTTng on external ntirpc
167a28c Jiffin Tony Thottan rpc_callback : check return value for
nfs_rpc_create_chan_v40() properly
3309f80 Soumya Koduri FSAL_GLUSTER/lock_op: Unlock state's fdlock incase of
error
d795bbf Soumya Koduri FSAL_GLUSTER: APIs to recall delegation from backend
f4bff1d Soumya Koduri FSAL_GLUSTER: restore creds from the saved open_fd
2ee60d9 Soumya Koduri FSAL_GLUSTER: Support new lease fop
c62d842 Soumya Koduri FSAL_GLUSTER: Set LEASE ID for all the operations
ff286ee Soumya Koduri Enable delegations for FSAL_GLUSTER
6 years, 1 month
Change in ffilz/nfs-ganesha[next]: Add nfs_req_result type and convert nfs4 compound ops to return it
by GerritHub
From Frank Filz <ffilzlnx(a)mindspring.com>:
Frank Filz has uploaded this change for review. ( https://review.gerrithub.io/430998
Change subject: Add nfs_req_result type and convert nfs4 compound ops to return it
......................................................................
Add nfs_req_result type and convert nfs4 compound ops to return it
Instead of returning the redundant nfsstat4, return nfs_req_result.
We add a new value also NFS_REQ_ERROR (which is used by nfs4_Compound
to determine if it should stop the loop).
This will be more meaninfull once we add a nfs_req_result to indicate
a need to suspend an async request.
Change-Id: I05029037bf09e32a678cfaf56b74e47d60cb62f9
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
---
M src/Protocols/NFS/nfs4_Compound.c
M src/Protocols/NFS/nfs4_op_access.c
M src/Protocols/NFS/nfs4_op_allocate.c
M src/Protocols/NFS/nfs4_op_bind_conn.c
M src/Protocols/NFS/nfs4_op_close.c
M src/Protocols/NFS/nfs4_op_commit.c
M src/Protocols/NFS/nfs4_op_create.c
M src/Protocols/NFS/nfs4_op_create_session.c
M src/Protocols/NFS/nfs4_op_delegpurge.c
M src/Protocols/NFS/nfs4_op_delegreturn.c
M src/Protocols/NFS/nfs4_op_destroy_clientid.c
M src/Protocols/NFS/nfs4_op_destroy_session.c
M src/Protocols/NFS/nfs4_op_exchange_id.c
M src/Protocols/NFS/nfs4_op_free_stateid.c
M src/Protocols/NFS/nfs4_op_getattr.c
M src/Protocols/NFS/nfs4_op_getdeviceinfo.c
M src/Protocols/NFS/nfs4_op_getdevicelist.c
M src/Protocols/NFS/nfs4_op_getfh.c
M src/Protocols/NFS/nfs4_op_illegal.c
M src/Protocols/NFS/nfs4_op_layoutcommit.c
M src/Protocols/NFS/nfs4_op_layoutget.c
M src/Protocols/NFS/nfs4_op_layoutreturn.c
M src/Protocols/NFS/nfs4_op_link.c
M src/Protocols/NFS/nfs4_op_lock.c
M src/Protocols/NFS/nfs4_op_lockt.c
M src/Protocols/NFS/nfs4_op_locku.c
M src/Protocols/NFS/nfs4_op_lookup.c
M src/Protocols/NFS/nfs4_op_lookupp.c
M src/Protocols/NFS/nfs4_op_nverify.c
M src/Protocols/NFS/nfs4_op_open.c
M src/Protocols/NFS/nfs4_op_open_confirm.c
M src/Protocols/NFS/nfs4_op_open_downgrade.c
M src/Protocols/NFS/nfs4_op_openattr.c
M src/Protocols/NFS/nfs4_op_putfh.c
M src/Protocols/NFS/nfs4_op_putpubfh.c
M src/Protocols/NFS/nfs4_op_putrootfh.c
M src/Protocols/NFS/nfs4_op_read.c
M src/Protocols/NFS/nfs4_op_readdir.c
M src/Protocols/NFS/nfs4_op_readlink.c
M src/Protocols/NFS/nfs4_op_reclaim_complete.c
M src/Protocols/NFS/nfs4_op_release_lockowner.c
M src/Protocols/NFS/nfs4_op_remove.c
M src/Protocols/NFS/nfs4_op_rename.c
M src/Protocols/NFS/nfs4_op_renew.c
M src/Protocols/NFS/nfs4_op_restorefh.c
M src/Protocols/NFS/nfs4_op_savefh.c
M src/Protocols/NFS/nfs4_op_secinfo.c
M src/Protocols/NFS/nfs4_op_secinfo_no_name.c
M src/Protocols/NFS/nfs4_op_sequence.c
M src/Protocols/NFS/nfs4_op_set_ssv.c
M src/Protocols/NFS/nfs4_op_setattr.c
M src/Protocols/NFS/nfs4_op_setclientid.c
M src/Protocols/NFS/nfs4_op_setclientid_confirm.c
M src/Protocols/NFS/nfs4_op_test_stateid.c
M src/Protocols/NFS/nfs4_op_verify.c
M src/Protocols/NFS/nfs4_op_write.c
M src/Protocols/NFS/nfs4_op_xattr.c
M src/include/nfs_proto_data.h
M src/include/nfs_proto_functions.h
59 files changed, 688 insertions(+), 568 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/98/430998/1
--
To view, visit https://review.gerrithub.io/430998
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I05029037bf09e32a678cfaf56b74e47d60cb62f9
Gerrit-Change-Number: 430998
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx(a)mindspring.com>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: Strip out WRITE_PLUS code
by GerritHub
From Frank Filz <ffilzlnx(a)mindspring.com>:
Frank Filz has uploaded this change for review. ( https://review.gerrithub.io/430997
Change subject: Strip out WRITE_PLUS code
......................................................................
Strip out WRITE_PLUS code
WRITE_PLUS was replaced with WRITE_SAME which is enough different
from WRITE that it will need entirely different code.
Change-Id: I99ce7570556824b5fa76561b60d0b7cd74809c22
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
---
M src/FSAL/FSAL_CEPH/handle.c
M src/FSAL/FSAL_GLUSTER/handle.c
M src/FSAL/FSAL_GPFS/file.c
M src/FSAL/FSAL_GPFS/fsal_ds.c
M src/FSAL/FSAL_MEM/mem_handle.c
M src/FSAL/FSAL_PROXY/handle.c
M src/FSAL/FSAL_RGW/handle.c
M src/FSAL/FSAL_VFS/file.c
M src/FSAL/default_methods.c
M src/Protocols/NFS/nfs4_op_read.c
M src/Protocols/NFS/nfs4_op_write.c
M src/include/fsal.h
M src/include/fsal_api.h
M src/include/nfsv41.h
14 files changed, 34 insertions(+), 335 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/97/430997/1
--
To view, visit https://review.gerrithub.io/430997
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I99ce7570556824b5fa76561b60d0b7cd74809c22
Gerrit-Change-Number: 430997
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx(a)mindspring.com>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: Move setting of resp->resop for nfs4_read for clarity
by GerritHub
From Frank Filz <ffilzlnx(a)mindspring.com>:
Frank Filz has uploaded this change for review. ( https://review.gerrithub.io/430996
Change subject: Move setting of resp->resop for nfs4_read for clarity
......................................................................
Move setting of resp->resop for nfs4_read for clarity
nfs4_read with setting resp->resop, but since READ_PLUS uses a response
structure on the stack to call nfs4_read it doesn't get overwritten
but it's not entirely clear, so add clarity.
Change-Id: Icf8edb8bdbf19ede75a4d6f624410db82d6876de
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
---
M src/Protocols/NFS/nfs4_op_read.c
1 file changed, 6 insertions(+), 6 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/96/430996/1
--
To view, visit https://review.gerrithub.io/430996
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: Icf8edb8bdbf19ede75a4d6f624410db82d6876de
Gerrit-Change-Number: 430996
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx(a)mindspring.com>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: nfs4_op_open: NULL pointer bug - replace goto out3 with return
by GerritHub
From Frank Filz <ffilzlnx(a)mindspring.com>:
Frank Filz has uploaded this change for review. ( https://review.gerrithub.io/430995
Change subject: nfs4_op_open: NULL pointer bug - replace goto out3 with return
......................................................................
nfs4_op_open: NULL pointer bug - replace goto out3 with return
I'm not sure how this got missed by Coverity...
Change-Id: I26cfab5b3fab7ddf528d81a8d3439cd14e70793b
Signed-off-by: Frank S. Filz <ffilzlnx(a)mindspring.com>
---
M src/Protocols/NFS/nfs4_op_open.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/95/430995/1
--
To view, visit https://review.gerrithub.io/430995
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I26cfab5b3fab7ddf528d81a8d3439cd14e70793b
Gerrit-Change-Number: 430995
Gerrit-PatchSet: 1
Gerrit-Owner: Frank Filz <ffilzlnx(a)mindspring.com>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: Fix NFSv3 EOF handling.
by GerritHub
From Dmitry Prokoptsev <dprokoptsev(a)yandex.ru>:
Dmitry Prokoptsev has uploaded this change for review. ( https://review.gerrithub.io/430968
Change subject: Fix NFSv3 EOF handling.
......................................................................
Fix NFSv3 EOF handling.
This was originally fixed in a8858a4a1, but apparently broken in 82148ac9
by misplacing the EOF check.
Change-Id: I1bb788c81d179bd9875dec7e72da1be5e3fe8248
Signed-off-by: Dmitry Prokoptsev <dprokoptsev(a)google.com>
---
M src/Protocols/NFS/nfs3_read.c
1 file changed, 3 insertions(+), 3 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/68/430968/1
--
To view, visit https://review.gerrithub.io/430968
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I1bb788c81d179bd9875dec7e72da1be5e3fe8248
Gerrit-Change-Number: 430968
Gerrit-PatchSet: 1
Gerrit-Owner: Dmitry Prokoptsev <dprokoptsev(a)yandex.ru>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: FSAL_CEPH: add a "filesystem" export parameter
by GerritHub
From Jeff Layton <jlayton(a)redhat.com>:
Jeff Layton has uploaded this change for review. ( https://review.gerrithub.io/430961
Change subject: FSAL_CEPH: add a "filesystem" export parameter
......................................................................
FSAL_CEPH: add a "filesystem" export parameter
Allow exporting alternate cephfs filesystems within the same cluster.
This is supported on more recent versions of libcephfs. In the event
that the library doesn't support it, fail export creation when someone
tries to set the new parameter.
Change-Id: I7c365b651b5408729b80cbdd1ea0a53e8fa80c48
Signed-off-by: Jeff Layton <jlayton(a)redhat.com>
---
M src/CMakeLists.txt
M src/FSAL/FSAL_CEPH/internal.c
M src/FSAL/FSAL_CEPH/internal.h
M src/FSAL/FSAL_CEPH/main.c
M src/cmake/modules/FindCEPHFS.cmake
M src/config_samples/ceph.conf
M src/doc/man/ganesha-ceph-config.rst
M src/include/config-h.in.cmake
8 files changed, 76 insertions(+), 2 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/61/430961/1
--
To view, visit https://review.gerrithub.io/430961
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: I7c365b651b5408729b80cbdd1ea0a53e8fa80c48
Gerrit-Change-Number: 430961
Gerrit-PatchSet: 1
Gerrit-Owner: Jeff Layton <jlayton(a)redhat.com>
6 years, 2 months
Change in ffilz/nfs-ganesha[next]: FSAL_CEPH: add FS cluster ID into the FSAL_CEPH filehandle
by GerritHub
From Jeff Layton <jlayton(a)redhat.com>:
Jeff Layton has uploaded this change for review. ( https://review.gerrithub.io/430960
Change subject: FSAL_CEPH: add FS cluster ID into the FSAL_CEPH filehandle
......................................................................
FSAL_CEPH: add FS cluster ID into the FSAL_CEPH filehandle
Currently, the FSAL-specific portion of the filehandle is composed of a
vinodeno_t, which is just an inode number and snapid tuple.
In a follow-on patch we're going to allow exporting alternate, named
filesystems within the same cluster. At that point, the vinodeno_t is no
longer unique enough for this purpose.
This patch expands the ceph_handle with a new 64-bit fscid field, that
denotes the cluster ID within the filesystem. From there, teach the
cluster to encode the fscid in the handle when it's available.
Ceph reserves fscid 0 to denote "legacy" filesystems. If no filesystem
name string is specified, or if it is a legacy filesystem, then we don't
append the fscid to the handle, in order to maintain backward
compatibility.
Change-Id: Id8818f181f9abeb49b2845c551e6e2b83e80db9b
Signed-off-by: Jeff Layton <jlayton(a)redhat.com>
---
M src/FSAL/FSAL_CEPH/export.c
M src/FSAL/FSAL_CEPH/handle.c
M src/FSAL/FSAL_CEPH/internal.c
M src/FSAL/FSAL_CEPH/internal.h
4 files changed, 31 insertions(+), 14 deletions(-)
git pull ssh://review.gerrithub.io:29418/ffilz/nfs-ganesha refs/changes/60/430960/1
--
To view, visit https://review.gerrithub.io/430960
To unsubscribe, or for help writing mail filters, visit https://review.gerrithub.io/settings
Gerrit-Project: ffilz/nfs-ganesha
Gerrit-Branch: next
Gerrit-MessageType: newchange
Gerrit-Change-Id: Id8818f181f9abeb49b2845c551e6e2b83e80db9b
Gerrit-Change-Number: 430960
Gerrit-PatchSet: 1
Gerrit-Owner: Jeff Layton <jlayton(a)redhat.com>
6 years, 2 months